Histoire de cap et de NMEA

Sujet du forum - Posté par Maxspeed le 28 décembre, 2005 - 18:38
Aucun vote pour l'instant.

Au secours !
Si une bonne âme peut résoudre cette énigme ....

Alors, voilà : sur le bateau je dispose d'un anémo-gyrouette et d'un loch sondeur (Multi) de marque Navman (3150 et 3100). Il y a également un GPS MLR 312 ainsi qu'un pilote automatique autohelm ST4000+.
Tout ce petit monde est relié via un multiplexeur (Brookhouse) et doivent théoriquement envoyer leurs informations à un PC portable par le port USB.
Hors, j'obtiens toutes les données souhaitables et plus encore SAUF les infos du gyro-compas du pilote automatique.... et c'est là le hic ! J'en ai besoin pour faire tourner un logiciel d'acquisition de polaire (plus précisément pour étalonner la centrale).

Dans le détail : les 2 Navman communiquent entre eux par le Navbus. Ils sont par ailleurs reliés au multiplexeur en NMEA. Le GPS a sa sortie NMEA reliée au multiplexeur. Le ST4000+ est relié au multiplexeur en NMEA et en Seatalk.

Est-ce que quelqu'un a déjà été confronté à ce problème ? Les données du compas sont-elles normalement disponibles en sortie NMEA ou en Seatalk (ou pas du tout) ?

Merci d'avance pour vos réponses ! ça fait des jours que je bidouille et je donne ma langue au chat !

Bon bout d'an à toutes et tous !

tschai
L'utilisateur est Offline. Vue la dernière fois à 6 an 9 semaines. Hors ligne
Maître
Posté par tschai, le 28 décembre, 2005 - 20:38

Salut Maxspeed,

J'suis très surpris que tu souhaites faire de l'acquisition de polaire avec du Navman !!!! 8O Déjà avec des centrales beaucoup plus pointues c'est Rock'n Roll alors avec du plastimerde...... lol bref passons.
Tu parles aussi de gyro-compas sur un 4000???? 8O En fait tu veux récupérer l'info cap du fluxgate. La donnée cap d'un fluxgate sur un ST 2/3/4/5/6/7000 n'est pas assez précise et stable pour faire de l'acquisition .... enfin tu veux bidouiller et t'amuser j'comprend, j'ai passé des heures là dedans aussi !! Eye-wink

Branche en direct le 4000 sur le pc et regarde ce qu'il balance (via Hyper Terminal ou autre). Il est probable qu'il ne sort que du HDM ou HDG (cap magnétique) alors que tu as besoins d'une info HDT (cap vrai).
La donnée HDM/G est dispo sur le SeaTalk et vraissembablement aussi sur le NMEA.
Maintenant pour que ton pilote te génère du HDT il lui faut soit l'info pos du GPS, off course, ou il faut que tu rentres en manuel la déclinaison.
Ou encore, sans rien il se peut qu'il sorte du HDT mais avec la même valeur que le HDM/G, vérifie avec le pc en direct.

Ensuite si ton pilote est branché sur ton multiplexeur en NMEA et SeaTalk, tu as peut être un conflit d'information entre les deux, ils ne bossent pas à la même vitesse donc pas le même damping donc peut être conflit interne dans le multiplexeur pour certaines données.
Ou encore conflit de donnée HDT entre les infos pilote (si il les envoie bien) et GPS, si tu envoies deux données HDT avec des valeurs différentes (forcement, même minime) le multiplexeur ne doit pas aimer, dans ce cas supprime dans ton GPS l'envoie de cette donnée car même si les HDT pilote et GPS ne parlent pas de la même donnée réelle, pour le multiplexeur si.

En général, vas y pas à pas. D'abord un, puis le copain, puis un autre, plus tu avances plus tu mettras en évidence une éventuelle incompatibilité invisible si tu branches tout d'un coup.
Ensuite, tu peux avoir également un conflit électrique, pas de format NMEA mais de niveau du signal, la compatibilité NMEA à des limites !!!

Essaye un peu tout ça et dis nous ce qu'il en est !

A+
Fred _/) Cool

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 28 décembre, 2005 - 22:12

Citer:
J'suis très surpris que tu souhaites faire de l'acquisition de polaire avec du Navman !!!! Shocked Déjà avec des centrales beaucoup plus pointues c'est Rock'n Roll alors avec du plastimerde...... lol bref passons.
Tu parles aussi de gyro-compas sur un 4000???? Shocked En fait tu veux récupérer l'info cap du fluxgate. La donnée cap d'un fluxgate sur un ST 2/3/4/5/6/7000 n'est pas assez précise et stable pour faire de l'acquisition .... enfin tu veux bidouiller et t'amuser j'comprend, j'ai passé des heures là dedans aussi !! Wink

Ben oui, je me suis fais "couillonné" quand j'ai acheté les Navman ... je recommencerais plus ! Promis !
Pardon aussi pour le terme non-approprié : il s'agit effectivement du compas flux-gate. Ceci dit pour l'acquisition à proprement parlé, je n'ai pas besoin du compas puisqu'on travaille en "relatif". L'info me servira uniquement pour étalonner la centrale (c'est en tout cas le processus avec le logiciel que j'ai).

Citer:
Branche en direct le 4000 sur le pc et regarde ce qu'il balance (via Hyper Terminal ou autre). Il est probable qu'il ne sort que du HDM ou HDG (cap magnétique) alors que tu as besoins d'une info HDT (cap vrai).
La donnée HDM/G est dispo sur le SeaTalk et vraissembablement aussi sur le NMEA.
Maintenant pour que ton pilote te génère du HDT il lui faut soit l'info pos du GPS, off course, ou il faut que tu rentres en manuel la déclinaison.
Ou encore, sans rien il se peut qu'il sorte du HDT mais avec la même valeur que le HDM/G, vérifie avec le pc en direct.

Je vais tout déconnecter sauf le PA mais par contre je ne pourrais pas passer en direct. Je suis obligé de passer par le multiplexeur (je suis tenu par la sortie USB et la conversion Seatalk).
Pour l'instant, je n'ai aucune info de cap (que ce soit HDM, HDT, HDG).

Citer:
Ensuite si ton pilote est branché sur ton multiplexeur en NMEA et SeaTalk, tu as peut être un conflit d'information entre les deux, ils ne bossent pas à la même vitesse donc pas le même damping donc peut être conflit interne dans le multiplexeur pour certaines données.
Ou encore conflit de donnée HDT entre les infos pilote (si il les envoie bien) et GPS, si tu envoies deux données HDT avec des valeurs différentes (forcement, même minime) le multiplexeur ne doit pas aimer, dans ce cas supprime dans ton GPS l'envoie de cette donnée car même si les HDT pilote et GPS ne parlent pas de la même donnée réelle, pour le multiplexeur si.

Je suis effectivement branché NMEA + Seatalk mais d'après ce que j'ai pu voir sur la doc du ST, le NMEA ne travaillerait qu'en "entrée" et le seatalk qu'en "sortie". Tu confirmes ?
Je crois avoir déjà supprimer du GPS l'info de cap, je vérifie demain.
Sur le ST, je n'ai pas rentré de valeur de déclinaison. Je vais en rentrer une pour voir si ça donne quelque chose sur "HyperTerminal".

Par ailleurs, connais-tu le multiplexeur de chez Brookhouse ? Il a l'option Seatalk sur le premier port et une sortie USB. Apparament on peut le "re-programmer", c'est-à-dire effacer des phrases NMEA ou les modifier. Peut-on le forcer à retranscrire ou à traduire du HDT ? Je m'exprime mal ... mais je ne maitrise pas ce genre de language (NMEA) ! Mais tu t'en seras rendu compte !! lol !

Merci en tout cas pour tes réponses. Je m'attelle à la tache dès demain sur le bateau ! Vive le chauffage à ce propos .... car les températures sont négatives en ce moment !

merlain
L'utilisateur est Offline. Vue la dernière fois à 41 semaines 4 jours. Hors ligne
Maître
Posté par merlain, le 28 décembre, 2005 - 22:47

Maxspeed a écrit :

Je suis effectivement branché NMEA + Seatalk mais d'après ce que j'ai pu voir sur la doc du ST, le NMEA ne travaillerait qu'en "entrée" et le seatalk qu'en "sortie". Tu confirmes ?

Bonsoir

Le câble Nmea est en fait deux fils, un jaune et un blanc.
Ce qui fait qu'il transfert juste une valeur (data simplex)
Le dialogue entre plusieur équipements GPS et radio, radar... est souvent fastidieux :roll:
Bon courage et tiens nous au courant Eye-wink
Je devrait bientôt moi aussi me battre avec ce genre d'équipements Puzzled

__________________

Bonne nav & bon vent !
merlain -)

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 28 décembre, 2005 - 23:48

A part le problème de cap, pas de souci majeurs de communication. Certes les navman envoient les infos un peu quand ils en ont envie .... mais sinon ça roule !
Je vous tiendrai au courant pour le cap ...

tschai
L'utilisateur est Offline. Vue la dernière fois à 6 an 9 semaines. Hors ligne
Maître
Posté par tschai, le 29 décembre, 2005 - 02:42

YEp,

Effectivement, le port NMEA du 4000 est une entrée, j'avais zappé qu'il n'avait pas de port de sortie NMEA ... c'est que ça commence à faire loin tout ça! Puzzled
Le SeaTalk est un bus, donc bidi, donc entrée/sortie.

Alors, j'ai trouvé sur le net ton boîtier et donc aussi la doc:
1- Attention: si tu utilises le port SeaTalk tu ne dois rien bancher sur le prot NMEA 1 !
2- Tu remarqueras qu'ils parlent pour une entrée pilote NMEA de "HDG from fluxgate" donc le boîtier digère du HDG, le contraire aurait été surprenant!
3- Si tu as un port série sur ton pc, essaye un peu de brancher la sortie RS232 du boîtier dessus: "RS232 TxD" sur pin 2 de la DB9, "RS232 GND" sur la pin 5.

Attention à l'alimentation: visiblement l'alim du boîtier se fait en // de l'alim du ST. Si tu n'as relié que le jaune entre le 4000 et la borne "ST Yellow sign" assure toi bien que les 12 et 0V du pilote et du boîtier soient les mêmes....

Je ne me souviens plus si sur un 4000, en balançant du 12V via le ST le boîtier s'allume .... la logique voudrait que non, maintenant Raymarine c'est anglais alors ... Laughing out loud
Pourquoi cette remarque? Parce que si c'est la cas, ton ST pilote étant branché en parralèlle de l'alim du boîtier, en alimentant le boîtier tu va alimenter le pilote, donc croire qu'il est en route même sans l'alim de puissance, ce qui pourrai expliquer qu'il n'envoie pas d'info sur le ST .... normal tant que l'alim de puissance n'est pas ON.

Pour ce qui est du chauffage, il me faudrai plutôt une clim, on est en été avec saison des pluies ... mais j'vais surement pas m'en plaindre même si l'intérieur de mon bébé ressemble parfois à un sona!!!! Laughing out loud

A+
Fred _/)
Cool

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 29 décembre, 2005 - 12:28

Salut Fred !

Citer:
Le SeaTalk est un bus, donc bidi, donc entrée/sortie.

Je vais donc essayer de débrancher le NMEA du pilote. Il se pourrait effectivement que les infos viennent en double.

Citer:
1- Attention: si tu utilises le port SeaTalk tu ne dois rien bancher sur le prot NMEA 1 !
2- Tu remarqueras qu'ils parlent pour une entrée pilote NMEA de "HDG from fluxgate" donc le boîtier digère du HDG, le contraire aurait été surprenant!
3- Si tu as un port série sur ton pc, essaye un peu de brancher la sortie RS232 du boîtier dessus: "RS232 TxD" sur pin 2 de la DB9, "RS232 GND" sur la pin 5.

Je n'ai rien branché sur le port 1. Par contre pour le "HDG from fluxgate", ils parlent d'une entrée NMEA, mais j'ai cru comprendre que c'est l'entrée sur le multiplexeur, ce qui doit correspondre à une sortie du PA. Sortie NMEA non disponible sur le ST !! Malheureusement, je n'ai pas de port série sur le PC !

Citer:
Pourquoi cette remarque? Parce que si c'est la cas, ton ST pilote étant branché en parralèlle de l'alim du boîtier, en alimentant le boîtier tu va alimenter le pilote, donc croire qu'il est en route même sans l'alim de puissance, ce qui pourrai expliquer qu'il n'envoie pas d'info sur le ST .... normal tant que l'alim de puissance n'est pas ON.

Alors là, il faut que je vérifie. Je n'ai pas touché à l'alim du ST. Par contre j'alimente le multiplexeur via le Seatalk pour le positif + une masse. Je vais essayer de cabler différent pour voir ce que ça donne.
Ce qui m'ennuie, c'est que d'apparence tout fonctionne bien : c'est-à-dire que sur "HyperTerminal", je reçoit des données NMEA introduites par les deux i (II), ce qui devrait signifier que ce sont à la base des données Seatalk traduites.
Sur la notice du Brookhouse, ils parlent d'une configuration à réaliser à l'intérieur du multiplexeur, afin qu'il soit capable de lire le Seatalk. Quand je l'ai acheté, on m'a dit qu'il n'y avait rien à faire, mais je vais quand même vérifier.

Merci pour tes recherches. Je descend au bateau pour voir tout ça !

Profites bien de la chaleur !!!!

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 29 décembre, 2005 - 19:12

Salut Fred !

Bon, je reviens du bateau et le chmiblik avance un peu :

Pour l'alimentation du multiplexeur, elle est bien fournie par la sortie seatalk du boitier du ST (3 fils dont 2 servent d'alim et 1 pour les infos). Pas de problème de ce côté là.

J'ai déconnecté les navman et GPS en ne gardant que le Seatalk du ST. J'aurais donc du récupérer info HGD, HDT ou HDM. au lieu de cela je reçoit des 3 (au format exposant) entrecoupé de - ou de barre verticale. J'ai même parfois des smileys !!!!

J'ai tout reconnecté un après l'autre (Navman, GPS) en NMEA et le ST en entrée NMEA. Les infos GPS et Navman arrivent bien au pilote qui peut les exploiter.

Sur HyperTerminal j'ai toutes les données (sauf le cap) avec toujours les petits 3 qui se promènent.

Trois hypothèses :

1- Soit le multiplexeur n'est en fait pas Seatalk et il ne reconnait donc pas la seule valeur (cap) émise en seatalk. Ceci me surprendrais, puisque j'avais achété au début ce même multiplexeur sans l'option seatalk et il ne transmettait aucune valeur en $II, ce que fait celui-ci.

2- Le multiplexeur traduit bien le Seatalk mais la donnée cap n'est pas présente sur le bus Seatalk. Dans ce cas, je ne vois pas pourquoi il balance des petits "3".

3- Le multiplexeur n'arrive pas à traduire la valeur de cap. Et dans ce cas, peut-on le forcer à reconnaître et à traduire cette valeur ?

Qu'en penses-tu ?
J'espère ne pas trop t'embêter avec toutes mes questions !!
@+
Pierre-Alain

tschai
L'utilisateur est Offline. Vue la dernière fois à 6 an 9 semaines. Hors ligne
Maître
Posté par tschai, le 29 décembre, 2005 - 20:58

Salut Pierre-Alain

L'idéal serait que tu nous fasses un copier/coller d'une dizaine de phrase NMEA que tu traites avec des douteuses, simple c'est du format texte sous HT.
Une phrase NMEA commence par un $ puis un identifiant, $GP : gps, $LC : Loran ..... Si tu vois un $II, comme tu le dis, c'est très vraisemblablement le boîtier qui génère cette phrase.
Maintenant si les données de cette phrase sont du charabia et pas organisé genre ""$GPGGA,133756,1736.2122,S,14935.1871,W,1,03,8.4,29.9,M,47.6,M,,*7D"" alors tu as un problème de format de codage, si c'était un problème de format électrique tu n'aurais pas le $II.
Comme ça, ça fait penser à un format erroné en entrée, donc en sortie le boîtier génère n'importe quoi, ton SeaTalk n'est peut être pas Ok....

Tu as forcement une info cap sur le SeaTalk, attention pas au format HDM/G/T car spécifique NMEA (entre autre), le ST est composé d'une série de couples de nombres hexadécimaux dans lesquels sont codés les données, dont le cap pour un pilote, c'est certain.

-> Vérifie donc que le ST de ton 4000 n'est pas sur les genoux .... Récupère une télécommande ST600R, ou un pupitre de pilote 6000/7000 ou encore un Multi ST50/60 et branche le sur le ST de ton 4000, tu verras si tu récupères les infos pilote via le ST.

Pour la chaleur t'inquiète, on en profite toute l'année et des bords de prés avec 30 noeuds en caleçon dans l'balcon avant est monnaie courante Laughing out loud !

A+
Fred_/)
Cool

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 29 décembre, 2005 - 22:13

Chalut !

Voici quelques phrases récupérées il y a quelque temps.

$PTTKD,6.2,,B*1B67W,17.0,$VWVLW,
$PTTKV,0.00,,0.00,1127.41,129.37,17.5,C*01
$GPAPB,V,V,,,N,V,V,,M,,,M,,M*47
$IIVWR,156,R,4.82,N,2.48,M,8.93,K*67W,,,,,0.00,N,0.00,K*47
$VWVLW,1127.
$IIVPW,0.0,N,0.0~üøüüüüüü|üüüüüüü|$IIVWR,173,R,4.85,N,2.50,M,8.98,K*65C,1
$SDDBT,20.2,f,6.2,M,3.4,F*35.41,12
$VWM
$GPGLL,43
$IIVPW,0.0,N,0.0,M*5245213,A*26,,,,,,,,,,,
$IIMWV,171,R,4.85,N,A*1D

$GPRMC,145214,A,4317.640,N,00522.2
$IIVWR,156,R,4.73,N,2.43,M,8.76,K*69
$GPZDA,145200,22,11,2005,+02,00*
$VWVHW,,,,,0.00,N,0.00,K*4D
$SDDBT,20.2,f,6.1,M,3.4,F*36
$SDDPT,6.1,0.0,*7C
$PTTKD,6.1,,B*18
$PTTKV,0.00,,0.00,1127.41,129.37,17.5,C*01
$IIVWR,155,L,5.39,N,2.77,M,9.98,K*7D
$IIVPW,0.0,N,0.0~$IIVWR,153,L,6.71,N,3.45,M,12.43,K*48
üüüüüüü|üüüüüüü|$IIVPW,0.0,N,0.0,M*52
$IIMWV,204,R,6.71,N,A*15

Les "3" dont je te parlais sur le post précédent se transforment en "üüüü" en copiant vers un éditeur de texte. Je n'avait pas de waypoint actif lorsque j'ai enregistré. Le bateau était à quai, donc normal que la vitesse ne soit pas renseignée.
Si je peux j'en ferai un autre demain. Il me semble qu'aujourd'hui il y avait pas de bugs autres que les "3", "ü" ici.
Pour moi, les $II viennent bien du ST. Et dans la majorité des cas, ils sont complets.
La séquence que j'ai notée aujourd'hui (sur papier, c'est balot !!) était dans cet ordre, avec phrases complètes :

$GPAPB $GPBWC $IIVWR $GPGLL $IIVPW $GPRMB $IIMWV $GPRMC üüüüüüü $PTTKW $GPVTG $VWVLW $GPZDA $GPRMB üüü et ça recommence.

Pour ce faire prêter un boitier de ST60, ça va pas être facile. Je vais voir ça !

Un grand merci !

@+ Pierre-Alain

tschai
L'utilisateur est Offline. Vue la dernière fois à 6 an 9 semaines. Hors ligne
Maître
Posté par tschai, le 30 décembre, 2005 - 01:16

Yep,

Négatif, les phrases $II ne viennent pas du SeaTalk puisque elles concernent les données du cadran vent plastimachin:
$IIVWR= donnée vent apparent
$IIVPW= VMG
$IIMWV= donnée vent sans info réel ou app.
En plus t'as pas de $IIVWT pour le vent réel .... Plouf dans l'eau tes polaires copain!
T'as plus qu’à espérer que ton soft d'intégration puisse le faire, à priori oui. (Au fait, t'utilise quoi comme soft??)
$GPZDA/RMC +.... viens du GPS.
$SDDBT/DPT données sondeur de ton multi plastittrucmuche
$VWVHW: cap et vitesse surface, attention cap venant de plastibidule, comme t'en as pas, valeur à 0.
$PTTKD: visiblement donnée sondeur, le B signifierai "below transducer".
$PTTKV: données vitesse surface, loch totalisateur et journalier, température de l’eau (17° 8O oulalala ça caille par chez vous Laughing out loud !)

Je reviens sur ce que je t'ai dis dans mon dernier mess.
Il n'est pas évident en fait que ce soit un problème de codage plutôt qu'un problème électrique, dans la partie: "$IIVPW,0.0,N,0.0~$IIVWR,153,L,6.71,N,3.45,M,12.43,K*48", il ne fini pas la phrase $IIVPW: t'as pas le checksum et un "~" à la place et pas de retour chariot avec la phrase $IIVWR (ça ça peut ponctuellement arriver sans impact).
Il y a des phrases incomplètes: "$VWM": on connaît pas l'identifiant et pas d'info, "$GPGLL,43": il en manque! On sait juste que t'es à 43° de lat...
Des perturbations électriques pourraient expliquer ce mauvais format.

Bref, c'est pas bon tout ça, heuuuuu as tu essayé un autre multiplexeur???
Non parce que là, vu la tronche de cet extrait, même sans parler du pilote et de l'info HDM/T t'as un problème copain !!

Par rapport à cet extrait et à ce que tu as noté:
Il n'est pas impossible justement que les "üüü..." viennent des données ST, c'est les seules qu'il te manque, donc là:
Soit ton SeaTalk venant du pilote est dégradé, soit ton multiplexeur n'est pas SeaTalk, ou cette fonction est OFF, ou encore il est en rideau.

A+
Fred_/)
Cool

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 30 décembre, 2005 - 10:50

Ah que merci pour ton analyse !

Première remarque : l'eau était encore chaude ! L'enregistrement dâte de plus d'un mois ! maintenant elle est à 14 °C Eye-wink

Citer:
Négatif, les phrases $II ne viennent pas du SeaTalk puisque elles concernent les données du cadran vent plastimachin:

Il est vrai que ce sont les données vents. Mais quand je ne branche pas le PA au Multiplexeur (donc que GPS et Plastimoche) je n'ai plus ces données en integrated instrument ($II). Ils ne restent que les phrases "originelles" $VW, $SD etc .... Donc pour moi, les $II étaient les donées vents "digérées" et restituées par le PA.

Citer:
En plus t'as pas de $IIVWT pour le vent réel .... Plouf dans l'eau tes polaires copain!
T'as plus qu’à espérer que ton soft d'intégration puisse le faire, à priori oui. (Au fait, t'utilise quoi comme soft??)

L'enregistrement dâte de plus d'un mois, quand j'étais en cours de cablage. Tout fonctionne maintenant : je vais essayer de prendre le temps de refaire un enregistrement aujourd'hui.
Le logiciel est "Aquilon" de Olivier Desport et j'arrive à sortir les polaires. J'ai simplement des arrêts temporaires d'enregistrements par instant. Mais il semble que ce soit un problème des Navman d'après plastimoche. Ils auraient des bugs de transmissions en sortie NMEA (c'est pour ça que je les laissent couplés en parallèle en Navbus).

Pour les phrases incomplètes, je n'ai presque plus de problème à ce jour. Par contre, après les "3", il raccroche pas à la ligne (c'est logique, puisqu'il n'a pas les données de fin de ligne).

Citer:
Par rapport à cet extrait et à ce que tu as noté:
Il n'est pas impossible justement que les "üüü..." viennent des données ST, c'est les seules qu'il te manque, donc là:
Soit ton SeaTalk venant du pilote est dégradé, soit ton multiplexeur n'est pas SeaTalk, ou cette fonction est OFF, ou encore il est en rideau.

Foncton OFF ou multi non seatalk : dans la notice du multiplexeur, il est précisé que dans le menu de configuration on peut choisir d'avoir les données en sortie sous forme de "II" ou de "ST" ou NMEA + Seatalk OFF. Quand j'essaye de modifier les options, il ne m'accepte que le NMEA et Seatlak OFF. Je vais vérifier auprès du fournisseur.

Pour l'émission Seatalk du PA, je vais voir auprès d'Accastillage Diffusion, s'ils peuvent le tester sans l'envoyer chez le fabriquant.

Je t'envoie les nouvelles données cet après-midi (enfin je veux dire dans quelques heures : c'est peut-être plus clair vu ta position géographique !!)

@+ Pierre-Alain

tschai
L'utilisateur est Offline. Vue la dernière fois à 6 an 9 semaines. Hors ligne
Maître
Posté par tschai, le 30 décembre, 2005 - 20:11

Eye-wink

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 30 décembre, 2005 - 23:12

Salut Fred !

Comme tu peux le voir ci-dessous, on bat des records ! 10°C c'est la température au fond du Port de Marseille ! Effectivement ça change de Papeete (tu es bien à Papeete, non ?)!!! Eye-wink

Voici donc une partie de l'enregistrement d'aujourd'hui : mais ça tu peux le voir c'est écrit dedans !

$IIVPW,0.0,N,0.0,M*52 (normal puisque bateau arrêté)
$IIMWV,251,R,3.61,N,A*11 (ok)
$GPRMC,154513,A,4317.639,N,00522.208,E,000.0,135,301205,000,W*63 (ok)
ü€àüüüüÀð|üüüüü´‘üüüü| (pas glop !) $PTTKW,109,P,004,B,00.0*60 (j'sais plus ce que c'est !)
$GPVTG,135,T,000,M,000.0,N,000.0,K*49 (ok)
$VWVLW,1217.59,N,219.55,N*7F (ok)
$GPZDA,154513,30,12,2005,+02,00*61 (ok)
$VWMTW,10.0,C*13 (ok, mais trop froid !)
$GPAPB,A,A,0.00,L,N,V,V,117,M,AJACCI,117,M,017,M*20 (ok)
$VWVHW,,,,,0.00,N,0.00,K*4D (normal puisque pas de réception de cap et bateau arrêté)
$GPBWC,154514,4154.93,N,00844.43,E,118,T,118,M,170.6,N,AJACCI*01 (ok)
$SDDBT,20.5,f,6.2,M,3.4,F*32 (ok, et oui il y a 6m de fond !)
~$GPGLL,4317.639,N,00522.208,E,154514,A*28 (ok)
$VWVLW,1217.59,N,219.55,N*7F (ok: le loch a été changé, le bateau n'est pas neuf !)
$GPRMB,A,0.00,L,-WPT--,AJACCI,4154.939,N,00844.439,E,170.6,118.0,00.00,V*42 (ok)
$VWMTW,10.0,C*13 (ok)
$VWVHW,,,,,0.00,N,0.00,K*4D
üüüü´‘üüÀð|üüüüh!üüüààü$SDDBT,20.4,f,6.2,M,3.4,F*33
$GPRMC,154515,A,4317.639,N,00522.208,E,000.0,135,301205,000,W*65
$SDDPT,6.2,0.0,*7F
$GPVTG,135,T,000,M,000.0,N,000.0,K*49
$PTTKD,6.2,,B*1B
$GPZDA,154516,30,12,2005,+02,00*64
$PTTKV,0.00,,0.00,1217.59,219.55,10.1,C*0F
$GPAPB,A,A,0.00,L,N,V,V,117,M,AJACCI,117,M,017,M*20
$IIVWR,136,L,3.39,N,1.74,M,6.28,K*~$GPBWC,154516,4154.93,N,00844.43,E,118,T,118,M,170.6,N,AJACCI*03
$VWVLW,1217.59,N,219.55,N*7F
$GPGLL,4317.639,N,00522.208,E,154517,A*2B
$VWMTW,10.1,C*12
$VWVHW,,,,,0.00,N,0.00,K*4D
$GPRMB,A,0.00,L,-WPT--,AJACCI,4154.939,N,00844.439,E,170.6,118.0,00.00,V*42
üüüü´‘üüüü|üüüü´‘üü ð|ü$SDDBT,20.4,f,6.2,M,3.4,F*33
$GPRMC,154518,A,4317.639,N,00522.208,E,000.0,135,3

Je suis passé chez AD et ils ont eu la gentillesse de me prêter une télécommande de pilote automatique (ST100). Et ... le seatalk du PA fonctionne (toutes fonctions actives sur la télécommande et indication du cap compas). Comme quoi, l'information du cap est bien disponible sur le Seatalk.
Par ailleurs, j'ai envoyé un mail au fournisseur du multiplexeur et j'attends sa réponse (il est en vacance donc je risque de ne pas l'avoir tout de suite).

A part le problème électrique mais que j'ai encore vérifié aujourd'hui, il ne reste plus, soit un dysfonctionnement du mux (mux non seatalk), soit une mauvaise configuration de ma part.

Ah, au fait ! le copain de chez AD a sauté au plafond quand je lui ai dit que j'avais du Navman, d'autant plus que c'est son collègue qui me l'avait vendu !! J'aurais mieux fait de rester au ST !!

@+ Pierre-Alain[/i]

tschai
L'utilisateur est Offline. Vue la dernière fois à 6 an 9 semaines. Hors ligne
Maître
Posté par tschai, le 31 décembre, 2005 - 03:24

Yep,

Oui oui c'est bien à Papeete, enfin mon bateau est à Punaauia, 6 milles dans le sud de PPT, mais vu de chez vous ça change pas grand chose !!!! lol
Oui effectivement une eau à 10° c'est de la science fiction pour moi aujourd'hui, déjà quand le lagon descend à 24° on ne s'y baigne plus alors .... Laughing out loud Laughing out loud Laughing out loud Laughing out loud Laughing out loud Allez faire un tour sur l'album, j'y ai mis hier quelques photos sympa ... Ceci dit attendez peut être juin pour les regarder, ça vous fera moins mal !!! Laughing out loud Laughing out loud Laughing out loud Cool

C'est sûr que le Navman n'est pas du tout orienté pour faire ce que visiblement tu souhaites faire !!!!!! De toute façon Plastimo fait de tout, quand tu fais tout tu ne peux excellé dans un domaine donc .........
L'acquisition de polaire est en plus une discipline comment dire.... olympique! Même avec du matos de pro c'est pas évident du tout. J'avais eu la chance lors d'un dernier salon nautiques de Panam de discuter avec un électronicien/informaticien marine qui avait bossé pour l'équipe 6ème sens dans l'avant dernière coupe de l'America, il m'avait avoué que même dans ce secteur, plus que top en la matière, ils rencontraient de grosses difficultés pour arriver à des données très fiables. A la base il faut déjà du matos terrible, ça ils l'ont! Mais après les softs et autres moulinettes qui digèrent toutes ces données sont d'une complexité telle que beaucoup en perde leur latin! Dans beaucoup de cas, l’acquisition est dynamique, c'est-à-dire que les polaires sont quasiment remises à jour en permanence, plus de coefficient de conditions de mer ou autre que t’applique sur une polaire figée, elles changent tout le temps en fonction des conditions.
Evidement pour nous, nos chtites polaires nous suffises pour avoir une idée générale, une tendance, mais pas pour gagner ¼ de nœud.
Pour faire ce genre d'acquisition, le top « accessible » c'est B&G avec sa gamme Hercules, qui est une extension "compétition" de la gamme Hydra. Présente sur 100% des V070 et super yacht et ~60-70% des 50-60' Open, mono ou multi et du B&G spécial développement pour les Class America en plus d'une marque amerloc dont j'ai oublié le nom.
NKE commence depuis quelques années à venir les titiller dans leur terrain favori: la course au large.
La centrale Topline n'a plus grand chose à envier à l'Hydra de BG, sauf le prestige et l'expérience, par définition ça viendra.
Seul ombre au tableau évidement .... Le prix. T'as vite fait d'atteindre des sommets Elyséens !!!!
Alors pour nous, le ST60 ou le H1000 de B&G suffit amplement même en ayant quelques exigences avec nos voiles, le reste (Plastimo, Nasa ...) ça peut aller sur un bateau pirate Playmobil ou des barcasses à moteurs.... là j'vais m'faire des copains dans l'forum ! Laughing out loud Laughing out loud Laughing out loud !!

Bon revenons à nos moutons !
Tu as quelques instabilités dans tes phrases NMEA mais pas assez importantes pour que tu puisses remarquer l’impact à l’utilisation, à priori.
On retrouve encore les fameux « üüü|üü|üüü », et comme ils débarquent à des intervalles qui paraissent réguliers (tjrs à coté du RMC), à tous les coups c’est ce qui devrait venir du SeaTalk.
Ok alors visiblement si ton ST est ok le grain de sable vient de ton multiplexeur, bon ben tu va y arriver! A bientôt les polaires donc! Tu montreras ? C'est un mini que tu as non?

Aller, joyeux réveillons à tous et sans aucune retenue !!!

Fred _/)
Cool

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 31 décembre, 2005 - 11:13

Yo !

Punaauia ... je le note ! Que je languis le jour où mon étrave pointera sur ces îles !

Quand j'aurais fini de payer mes voiles, j'envisage de revendre les navman (si quelqu'un n'en veut !) pour reprendre du ST. C'est encore le plus abordable. Et au moins ce sera directement compatible avec le PA. Plastimo, que j'avais contacté suite à un défault d'étanchéité sur les boitiers, m'avait dit qu'ils pouvaient faire une mise à jour du soft pour rêgler le problème d'émission aléatoire des phrases NMEA. Dès la fin de la saison de régates, je vais les leur renvoyer pour la mise à jour. Je suis un peu têtu, et quand je prend quelque chose pour un usage, et qu'il est vendu pour, je tiens à ce qu'il le fasse ! Nous verrons bien !

Sinon pour les polaires, le logiciel Aquilon, dédiée uniquement à l'acquisition et aux speed tests (en gros) correspond à l'usage que je souhaite en faire. Pour l'instant, et malgré les problèmes de connection et de cap (donc avec une centrale mal étalonnée), il nous a déjà permis d'identifier clairement les angles optimum de changement de voile (génois-spi par exemple), ainsi que de nous rendre compte qu'on naviguait un peu trop abattu et trop rapide. Le reste, c'est plus pour la culture générale !

Pour les instabilités notées, elles suffisent à suspendre l'enregistrement des données pendant 30s à 1 min. C'est génant pour les speed-tests.
J'attends la réponse du fournisseur du Multi : au moins maintenant, on sait presque où on en est !

Si j'ai le temps tout à l'heure (préparation du réveillon oblige lol!) je te fairais une copie d'écran des polaires obtenues en 2 ou 3 sorties, donc pas encore très précises.

Sinon, et non, je ne navigue pas sur Mini, mais sur First 35s5. Nous faisons diverses régates en rade de Marseille (Challenge d'hiver, massilia Cup, SNIM, Trophée Maurice Pommé, Immo Cup ... ce genre de chose) et l'été le bateau repasse en version croisière pour les promenades familiales et estivales sur la Corse, la Sardaigne ...
Et toi, tu es sur quel bateau ?

Bon bout d'an et à l'an qué ven !

merlain
L'utilisateur est Offline. Vue la dernière fois à 41 semaines 4 jours. Hors ligne
Maître
Posté par merlain, le 31 décembre, 2005 - 15:23

Ho Punaauia, de beaux souvenirs Cool

__________________

Bonne nav & bon vent !
merlain -)

tschai
L'utilisateur est Offline. Vue la dernière fois à 6 an 9 semaines. Hors ligne
Maître
Posté par tschai, le 5 janvier, 2006 - 23:47

Hello les copains,

Moi je suis sur un GinFizz. Et oui, le marché du voilier est ici inexistant donc tu prends ce qu'il y a. Je bave en ce moment sur un First35 1ère génération, modèle sur lequel j'ai fais de long long milles et fais mes armes, problème: vu que le marché est 0 arrive pas à vendre mon canot!!!!

8O Du Navman sur un 35s5 8O ah oui effectivement! Aller met nous du NKE ou du B&G !!!! Eye-wink

Alors Merlain tu connais Tahiti? T'es venu à quelle occasion?

A+
Fred _/)
Cool

tschai
L'utilisateur est Offline. Vue la dernière fois à 6 an 9 semaines. Hors ligne
Maître
Posté par tschai, le 6 janvier, 2006 - 03:26

Au fait MaxSpeed, tu nous montres tes polaires ?

Mauruuru

Cool

tschai
L'utilisateur est Offline. Vue la dernière fois à 6 an 9 semaines. Hors ligne
Maître
Posté par tschai, le 10 janvier, 2006 - 01:24

Yep,

J'ai été faire un tour sur le site d'Aquilon, très intéressant ce soft. Ca fait un moment que j’suis déconnecté de tout ça, il me semblait que les coureurs océaniques et autre utilisaient des systèmes de gestions dynamiques, MaxSpeed, toi qui est visiblement dans le monde de la régate, t’aurais pas des infos là-dessus ?

Merci,

A+_/)
Cool

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 11 janvier, 2006 - 15:25

Salut fred !

Désolé pour la réponse tardive, mais je suis fréquemment en déplacements ...

J'essaye depuis un moment d'envoyer des images des polaires obtenues mais ... pas moyen ! Comment fait-on ?

Bref ... ça galère ! Je repars 2 jours. J'essaierai de nouveau à mon retour !

Bonnes navs en attendant !

Pierre-Alain

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 22 février, 2006 - 23:41

Salut Fred !

Un grand silence depuis la tentive de poster une photo d'écran ! Là voici enfin !

Ce n'est qu'un essai. La centrale n'était toujours pas calibrée. Je n'arrivais pas, depuis plus de trois mois à récupérer en NMEA la phrase comportant les données de cap ! En fait cela venait du multiplexeur qui était incapable de traduire les données seatalk, issues du compas fluxgate Raymarine, en NMEA (alors qu'il est vendu à cette fin, entre autre). Après de nombreux essais, j'ai finalement décidé de tenter ma chance avec une interface seatalk-NMEA-PC de chez Raymarine. Et miracle aujourd'hui ... j'ai enfin l'ensemble des données nécessaires qui arrivent sur le PC ! A priori, même pas besoin de multiplexeur supplémentaire pour ordonner les flux NMEA. Le bus ne sature pas ... bref, ça roule.
Nous allons enfin pouvoir nous servir du logiciel Aquilon pour étalonner correctement la centrale et sortir des polaires "justes".

@+ pierre-alain

tschai
L'utilisateur est Offline. Vue la dernière fois à 6 an 9 semaines. Hors ligne
Maître
Posté par tschai, le 25 février, 2006 - 02:08

Wouaouuuu bing dans les mirettes!!!!

Top, avec ça mon gars t'a plus l'droit à l'erreur !! Laughing out loud

Il est protégé par dungle ce soft ?? :roll:

A+ et bon week-end les copains _/)
Cool

Maxspeed
L'utilisateur est Offline. Vue la dernière fois à 5 an 29 semaines. Hors ligne
Quartier-maître
Posté par Maxspeed, le 26 février, 2006 - 00:03

Non pas protégé par un dongle mais par un mot de passe. A chaque installation il faut demander un nouveau mot de passe par mail en donnant le code de la désinstallation précédente. En clair : il est pas craqué ! .... juste payé ! Mais ça vaut le coup !
Ce soft permet notament de pouvoir calibrer très précisément la centrale ainsi que d'avoir en temps réel ses perfos par rapport à la polaire, sans parler des speed-tests.
Bref, comme tu dit on a plus droit à l'erreur ! Et pourtant on en fait encore de très belles !!!!

@+ PA